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Objectives 

The purpose of this guide is to instruct a user new to Isode’s servers and management tools on 
getting started with M-Vault, Isode’s LDAP/X.500 Directory Server. 

At the end of this guide you will have: 

1: Become familiar with the terminology of some of the major Directory concepts  
2: Created a Directory Server 
3: Bulk loaded data into the directory from one of the sample LDIF files shipped with M-
Vault 
4: Added entries to and modified and deleted entries in that directory. 

 

You’ ll use 2 Isode management tools to achieve the objectives of this guide (both are installed 
as part of M-Vault): 

·  EDM is used to configure and manage the Directory Service. It is used for initially 
setting up the Directory Service. It can be used to operate Directory Servers and to 
maintain operational information for the modification and extension of the Directory 
Service (as opposed to user information, which is maintained by a Directory User 
Agent (DUA) such as Isode’s Sodium). 

·  Sodium (Secure Open Data, Identity and User Manager) is used to manage user 
information in the Directory (such as entries for people or organizational units). It 
allows you to manage user information on multiple Directory Servers across the 
network, bulk load & dump data, browse through the Directory & add, delete and 
modify entries. Sodium has additional capabilities that are not touched upon in this 
guide (such as support for strong authentication and signed operations), other 
evaluation guides will explore those features in more detail. 

Isode packages filenames always contain references to the version number of the package. For 
the purposes of this guide version number have been replaced with a generic ‘X’ . For 
example: M-Vault-14.0v1-0.i386.exe becomes M-Vault-XX.XvX-X.i386.exe. You should 
substitute the relevant version numbers when running commands or executing menu items 
that include package names. 

Requirements 

Before installing M-Vault on your machine, you should visit www.isode.com/evaluate/m-
vault.html to discover which operating systems are supported by Isode and apply for access to 
the password protected evaluation file pages. 
 

You will need to install the Java Development Kit (JDK) Version 5.0 or above before 
installing any other Isode applications. 

 
Each supported operating system has its own evaluation page which contains links to the files 
you need and installation instructions for that platform.  You will be emailed a user name and 
password for access as well as an evaluation licence file. By default the license file you 
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receive needs to be installed in \Isode\etc\license.dat. You may have chosen an alternative 
installation directory when installing the software, in which case you will have to place the 
license file there. 
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Terminology 

This section describes some of the major Directory concepts that you will encounter in this 
evaluation. Feel free to skip this section if you are already familiar with Directories. 

Prior to creating a new Directory Server, you need to decide what schema (data dictionary) 
you want to use and the structure of the Directory. One good way to plan this is to draw an 
chart of your company’s structure, as this will be very similar to the structure of the Directory 
that you create. Shown below is part of such a chart for a fictional company ‘Acme’ . An 
LDIF file containing this ‘Acme’  dataset is one of the sample files shipped with M-Vault and 
later in this guide you’ ll load and work with this data. 

In this organizational chart we can see entries for an organization (Acme), organizational 
units (Head Office, Labs, Sales, Marketing, etc), locations (the two buildings), people, an 
organizational role (Managing Director) and a Group of Names (the Management Team). 

 

The hierarchical structure of the information held in the Directory is called the Directory 
Information Tree (DIT). Most of the useful information, from the perspective of a user, is 
found at the lower levels of the DIT, while the top levels hold information that facilitates 
identification and navigation of entries across the hierarchy. 

Each entry in the Directory (such as a person, organizational unit or organization) has 
attributes which contain information about it. An attribute consists of an attribute type and 
one or more values. An entry for Eric Perez contains attributes like: 

t el ephoneNumber :  070 4166 2970 
mai l :  er i c . per ez@acmel absl di f demo. com 

In this example, telephoneNumber  and mail are attribute types, while 070 4166 2970 and 
er ic.perez@acmelabsldifdemo.com are values for these attribute types. 

Each entry must also have at least one attribute which is used to name the entry (naming 
attribute). This attribute forms the Relative Distinguished Name (RDN) for this entry. 



 

M-Vault Evaluation Page 5 

 

The examples below are all valid RDNs, where cn stands for the attribute type 
commonName, ou for organizationalUnitName, and o for organizationName: 

cn=Er i c Per ez 
ou=Mar ket i ng 
o=Acme 

An entry can have more than one naming attribute, although usually only one is used. 

You may adopt a more complicated naming system, involving multiple naming attributes, to 
distinguish between large numbers of entries located at a single level of the DIT. For 
example, if there are two employees in the Marketing department called John Smith, you 
could use the userId (uid) attribute type to distinguish between them: 

cn=John Smi t h+ui d=j r s 
cn=John Smi t h+ui d=cbs 

Each Directory entry also has a Distinguished Name (DN), which uniquely identifies the entry 
in the DIT. The DN is constructed by joining the RDNs of all the entries in the DIT at and 
above this entry, up to the root. For example, consider the following chart which shows the 
Directory Information Tree for the Sales department (an organizational unit) of Acme: 

 

This chart shows the RDN of each level of the hierarchy. To construct the DN for the entry 
for Joseph Miller, join the RDNs of all entries at and above this entry up to the root. 

The chart above shows the required information. Therefore, the DN for the entry for Joseph 
Miller is: 

cn=Joseph Mi l l er ,  ou=Sal es,  l =Coyot e Bui l di ng,  ou=Head Of f i ce,  o=Acme 

The DN of an entry thus shows its position in the DIT as well as identifying it. 

Note that the RDN of an entry must distinguish it from all other entries with the same parent, 
where a parent is the next level up in the DIT. This means that you cannot have two entries 
with the same RDN (e.g. cn=Joseph Miller) underneath the same parent (e.g. ou=Sales). 
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Creating a Directory Server 

In this section we use EDM to create a Directory Server for Acme; we then use EDM to start 
this Directory Server and open a connection to it. 

EDM is started differently on Windows and Solaris/Linux, but once started, the process, 
displays and commands are the same. 

Starting EDM on Windows 

1. Click Start, and from the Programs menu, select Isode RXX.X>Enterpr ise 
Directory Manager  (EDM). 

This displays the initial EDM screen. 

Starting EDM on Solaris/Linux 

1. Login as the user of the DSA account. You need to do this because the DSA 
configuration directory is created when you add a new Directory Server in EDM, and 
the DSA account must be the owner of the DSA configuration directory. 

2. Type the following command: 

% / opt / i sode/ sbi n/ edm 

This command uses the X11 windowing system; it will attempt to display either on 
the current display, or on the display that has been specified using the standard X11 
DISPLAY variable. 

Creating a New Directory Server with EDM 

In the following example we will be creating a standalone Directory Server which will 
represent the company Acme, illustrated in the Terminology Background section. 

To create a new Directory Server: 

1. From the File menu, select New>Directory Server . The initial Directory Server 
Creation Wizard screen is displayed. 

2. As this is a standalone Directory Server, leave Be used to master  information 
selected and click Next. 

The following screen is displayed: 
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3. From the I t will master  a: drop down list, select International Organization. 

4. In the o= text box, type ‘Acme International’ . This is the name of our example 
company. 

5. Click Next. The following screen is displayed: 

 

This screen allows you to enter the Distinguished Name of the Directory Server’s entry in the 
DIT. 

6. In this instance, leave the cn=dsa as the default dsa, and click Next. The following 
screen is displayed: 
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Click Edit next to the Presentation Address field to set up the Presentation Address. 

This displays the Presentation Address Editor: 

 

The Network address defaults to the IP address of your system. The default X.500 
(DAP/DSP/DISP) port is 19999. Unless this conflicts with anything, do not change it. 

By default, the Directory will allow LDAP access. You can disable LDAP access if you want, 
or change the default port if the default value conflicts with anything. 

The default port number for LDAP is 19389. 

7. After making any changes in the Presentation Address Editor, click OK. The 
Configuration path points to the directory location where the Directory Server 
configuration information is held. Unless a Directory Server has been previously 
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created on this system, the default will work. Otherwise, the last part of the directory 
path will need to be changed from dsa-db to something like dsa-db2 as no two 
Directory Servers can have the same configuration path directory name. 

The wizard will display an error if you specify a directory location that already exists. 

8. Edit the Configuration path, if necessary. 

9. Click Next. 

The DSA Manager’s password screen is displayed. 

10. Type in the password for the DSA Manager, and then re-enter it in the Confirm 
Password text box. 

NOTE: You must remember this password, as you will use it to connect to the Directory 
Server later on. 

11. Choose ‘high-performance’  when asked for a database type choice. 

12. Click Next to proceed to the final summary screen: 

 

When you are happy with the details on this screen, click Finish. 

A message box stating that the Directory Server has been created successfully is displayed. 
You now have to start the Directory Server. 

Starting the Directory Server 

To start the Acme International Directory Server: 

1. From the EDM Server menu, select Star t a server . The following screen is 
displayed: 
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2. From the Directory Server drop-down list, select the server that you just created. 

3. Click OK. 

The server will start, and a dialog box will confirm this. 

Opening a connection to the directory Server 

You can now open a connection to the Directory to see the structure. The process of 
connecting to the Directory is called binding. 

1. From the File menu, select Open. 

The following screen is displayed: 

 

2. From the Directory Server drop-down list, select the Acme International Directory 
Server. This will automatically fill in the User name field with the DSA Manager’s 
name. Don’ t change the User name. 

3. In the Password text box, enter the DSA Manager’s password. This password is the 
one you entered when you created the Directory Server. 

4. Click OK. 

The following view of the Directory is displayed: 
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You have now successfully: 

1: Created a Directory Server  
2: Started the Directory Server 
3: Connected to the Directory Server using EDM 
 
You are now ready to load, examine and manipulate data using Sodium. 
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Populating & Browsing a Directory using 
Sodium 

Isode provides a Directory User Agent (DUA) called Sodium as part of the M-Vault 
installation. Sodium can be used, amongst other things, to manage user information in a 
Directory. 

In this section we’re going to use Sodium to add some entries to the directory in pursuit of the 
DIT described in the section of this guide on Terminology. 

At the end of this section you will have: 

1: Established a connection to the directory you created in the previous section of this guide 
2: Bulk loaded a sample LDIF file into that directory.  
3: Learned how to add entries to that directory using Sodium 
4: Become familiar with the Sodium interface for browsing and searching a directory 

 

Starting Sodium on Windows 

Click Start and from the Programs menu, select Isode RXX.X> Secure Open Data, Identity 
and User  Manager  (Sodium) 

Starting Sodium on Solaris/Linux 

Type in the following command: 

% / opt / i sode/ bi n/ sodi um 

Binding to a Directory Server 

Select Bind > Connect from Sodium’s Session menu. As you have no currently configured 
binds, the Bind Profile Management screen will be displayed: 

 

Click on New: 
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In the Bind Profile Details screen, bind using DAP utilizing the information on access that 
you gathered from the Presentation Address Editor (Page 8) when setting up your directory in 
EDM. Binding using LDAP is also possible. The Base DN is optional and does not need to be 
filled in at this stage. 

Enter a logical Display Name and click on Next. 

In the next step, choose the Simple Authentication radio button and in the Bind DN field 
enter the full Distinguished Name for the user you wish to log in as. In this example we’ re 
using the DN of the Acme International DSA Manager: 

cn=DSA Manager ,  cn=dsa,  o=Acme I nt er nat i onal  

 

Click on Finish to save the profile and return to the Bind Profile Management screen which 
now lists ‘Acme International’ .  
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You can use the Bind Profile Management screen to modify a profile or copy it as a template 
for other connection configurations but we’re simply going to connect to Acme so, make sure 
it is highlighted and click on Connect. 

 

You set up a password for the DSA Manager when the database was created. Type that 
password into the Password field. 

 

You are now connected to the Directory Server and the initial World view is displayed. 
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Bulk-loading entries from a sample LDIF file 

M-Vault ships with a number of sample LDIF (LDAP Data Interchange Format) files. We’re 
going to load the default Acme International Data. Normally when bulk-loading data you 
would use the ‘Bulk Tools’  option in the ‘Operations’  menu. The sample data sets however 
are loaded from the ‘Help’  menu. 

 

 

Sample LDIF files 

M-Vault ships with sample LDIF files covering five ‘sample’  organizational scenarios; 
International commercial organization (the one we’re using in this guide), Aviation, Military, 
Public Key Infrastructure and Network Information Service (NIS). 
 
For more information on these sample LDIF files, see the section ‘What Next/Other 
Resources’  at the end of this guide. 

Data cannot be loaded directly under ‘World’  so firstly expand the tree by clicking on the ‘+’  
to reveal the current entries in the DIT. 

 

Clicking on any entry in the DIT will cause Sodium to read the entry in the Directory Server 
and display the results in the right-hand pane. 
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Make sure that you have the ‘Acme International’  Entry selected and then select Help > 
Load Demo Data from the menu. 

Click ‘OK’  after reading the information popup and you’ ll be presented with the LDIF Bulk 
Load Settings screen. 

 

Accept these default settings and click on ‘OK’  to proceed with the load, after which you’ ll 
get a Load Complete acknowledgement. 

 

Clicking on ‘OK’  will return you to the main Sodium screen and if you now expand the 
entries under Acme International you’ ll see that the sample data set has been loaded and now 
reflects the organizational diagram which we part examined in an earlier section. Clicking on 
any of the entries will reveal the detail of that entry in the right-hand pane (grouped into 
tabbed views). 
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Adding an entry/entries using Sodium 

As we have seen, the left hand pane of the Sodium interface shows a hierarchical tree view of 
the directory, clicking on the ‘+’  reveals the entries immediately below it in the DIT. 

Right-clicking on an entry in the DIT allows you, amongst other things, to add entries below 
the one you have selected. 

In this section we’re going to add another staff member to the Marketing department. First, 
right-click on the ‘ou=Marketing’  entry and select ‘Add Below’ . 

 

Select ‘Person’  from the Template list. 
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The next screen allows you to select optional template parts, choose ‘Organizational Person’  
and ‘ Internet Organizational Person’  

 

Note that some of these templates have linked dependencies, so when clicking on Internet 
Organizational Person, Sodium will automatically include the required Organizational Person 
template. Click Next and add the full name of the person being added to the directory.  
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Finally click on finish to add the entry. In most cases there will additional required attributes 
needed before the record can be committed (in this case it’ s ‘Surname’ ) and these will be 
highlighted. Add the required attribute of ‘Brown’  and finish by clicking the ‘Add’  button. 

 

You can quickly add another entry of the same type by clicking the ‘Add Another’  button at 
the bottom of the screen. 

 

Modifying and Deleting an Entry 

You can modify any entry in the tree by clicking on it and using the entry detail tabs 
displayed to the right. If you change any of the values for the entry, Sodium will enable an 
‘Apply’  button which, when clicked, will cause Sodium to attempt to modify the directory 
entry with the changes. 

You can delete an entry from the DIT by right-clicking on it and selecting ‘Delete. Please 
note that you cannot remove an entry with subordinate entries. In order to remove an entry 
and its subordinate entries you can use the ‘Bulk tools > Delete subtree’  menu item when 
right-clicking on an entry. 
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Searching 

You can search the DIT by right-clicking on an entry and selecting ‘search’  from the pop-up 
menu or by clicking on an entry and selecting Operations > Search from the main toolbar. In 
both cases a search will be performed on all entries below the currently selected one. 

Try this operation with the o=Acme entry. Select o=Acme and bring up the search box. In this 
example we’re going to search for entries where the surname equals Miller: 

 

Click on OK, and Sodium will return the results in a separate Tab, showing the entries that 
match the search request and their position in the DIT. 

 

Template View 

In the graphics above we’ve used the notation ‘sn’  to represent the surname attribute but you 
could equally type in ‘surname=Miller’ . You will have seen notations like this for attribute 
types before when we looked at the RDN of an entry on page 21.  

Up to this point we’ve been viewing entries in ‘Template’  mode. For a fuller view of the data 
you can switch to ‘Raw’  view using the drop-down menu in the top right-hand corner. Below 
we can see the Raw view of the entry for Joseph Miller. 
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You have now successfully: 

1: Established a connection to the Directory using Isode’s ‘Sodium’  Directory User Agent 
2: Become familiar with some aspects of the Sodium interface by adding, browsing and 
searching entries in the directory.  
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Understanding Templates 

Sodium displays entries that are read from the directory using one of a number of configured 
templates. The template used is based on the objectclasses of the entry being read. If the 
objectclasses do not match any template, a raw template is provided. Templates are also used 
when adding a new entry to a directory (see Page 17). 

Templates are stored in an XML file (located at the (SHAREDIR)/sodium/templates.xml) 
which is read when Sodium starts. You can edit the templates file using any XML or text 
editor. 

Each template in the XML file references a number of forms that are used by Sodium. In the 
example below we can see how Sodium’s choice of optional parts for the ‘person’  template 
are defined by the templates.xml file. 

 

 

Each ‘ form’  defines additional attributes for that entry, gathered into groups, displayed as tabs 
by sodium. In the example below ‘contact’ , ‘photo’  and ‘security’  named groups are defined 
for the ‘ Internet Organizational Person’  optional part. 
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These groups are displayed as tabs within Sodium.  

 

Multiple groups can use the same label. When a template uses forms that use multiple groups 
with the same label, the contents of the groups are merged together for that template. In this 
case the Contact tab contains additional fields defined by the Internet Organizational Person 
form. 

Each <editor> element can have several attribute types. 

In the example below we have added the attribute type ‘compulsory=”yes” ’  to the ‘mail’  
attribute type within the ‘ inet-org-person’  form referenced above. 

 

Causing Sodium to flag ‘mail’  as a compulsory field when new entries of this type are added. 
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You can find out more about template structure and editing by reading the Sodium section of 
the M-Vault Administration Guide, available for download from 
www.isode.com/support/docs.html. 
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What next/other resources? 

This evaluation guide has taken you through the process of setting up a basic directory, 
populating that directory using Sodium and exploring the directory. 

Sample LDIF Files 

During this evaluation guide we have looked at M-Vault and Sodium in the context of the 
‘Acme’  sample LDIF file shipped with M-Vault. In addition to the Acme file, four other 
sample LDIFs are shipped with M-Vault covering aviation, military, pki and NIS scenarios. 

Like the Acme file, each of these can be loaded from the Help>Load demo Data.. menu 
item. The bulk-load settings screen will default to the Acme data, clicking the ‘Browse’  
button will enable you to access the other data sets (the Aviation set is shown below). 

 

Strong Authentication Evaluation 

M-Vault and Sodium support X.509 based Strong authentication, a separate Strong 
Authentication evaluation is available from www.isode.com/evaluate/strong-auth.html. 

More on M-Vault 

For those interested in a deeper understanding of M-Vault, the M-Vault Administrator guide 
is available for download from www.isode.com/support/docs.html. 
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More product information on M-Vault can be found at www.isode.com/products/m-
vault.html. 

Directory Whitepapers 

Free Isode whitepapers are available from the website which cover all Isode products and 
solution areas. Isode whitepapers can found at http://www.isode.com/whitepapers/index.php, 
with whitepapers specific to Directory located at http://www.isode.com/whitepapers/white-
directory.html.  
 
If you want to be informed about new whitepapers, you can sign up for the Isode News email 
list at http://www.isode.com/company/news-request.php. 

 


