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M-Switch X.400 Evaluation 
Guide 

Configuring M-Switch X.400 using the Quick Configuration wizard. 

and Isode are trade and service marks of Isode Limited. 

All products and services mentioned in this document are identified by the trademarks or service 

marks of their respective companies or organizations, and Isode Limited disclaims any responsibility 

for specifying which marks are owned by which companies or organizations. 

Isode software is © copyright Isode Limited 2002-2006, All rights reserved. 

Isode software is a compilation of software of which Isode Limited is either the copyright holder or 

licensee. Acquisition and use of this software and related materials for any purpose requires a 

written licence agreement from Isode Limited, or a written licence from an organization licensed by 

Isode Limited to grant such a licence. 



Objectives �

This guide is intended for users evaluating the Isode X.400 or Internet server products, and as 
an introduction for anyone wishing to gain quick operational experience with these products. 
This document describes how to set up a simple evaluation system, using one of these 
options: 

� �  M-Switch X.400 (X.400 Message Transfer Agent) and M-Store X.400 (X.400 
Message Store)� �

� �  M-Switch Internet and M-Box (IMAP/POP3 Message Store)� �
� �  M-Switch MIXER, M-Store X.400 and M-Box� �

 
This wizard will create a directory based configuration, using Isode’s X.500 M-Vault 
Directory Server. 

At the end of this guide you will have: 

1. Used the Quick Configuration Wizard to set up X.400 messaging.  
2. Send and receive test messages using both X.400 P3 and X.400 P7. 
3. Examined the configuration using a number of Isode Management Tools, including:  
 - MConsole to examine M-Switch X.400©s queue and monitor operations. 
 - EMMA (Enterprise Messaging Management and Administration) to view the 
 directory-based configuration of the messaging servers. 
 - EDM (Enterprise Directory Manager) to view directory configuration. 
 - Sodium (Secure Open Data, Identity and User Manager) to view data in the 
 directory. 
 - Event Viewer to monitor log files. 
4. Experimented with extending the configuration by adding new users and learning how to 
set up a connection to another MTA. 

�

Requirements �

A list of supported platforms is available from http://www.isode.com/evaluate/supported-
platforms.html. 
 
To fetch the packages evaluators should go to http://www.isode.com/evaluation/, select the 
sub-directory for your operating system and download the packages. Customers should visit 
the customers web site at http://www.isode.com/customers. You will need a customer or 
evaluation username and password to access these pages. 
 
To obtain a password contact sales@isode.com or fill in the evaluation request form at 
http://www.isode.com/evaluate/evalrequest.php. If you do not already have one, you will be 
sent an evaluation license file which, after package installation, should be placed in your 
C:\Isode\etcv(Windows) or /etc/isode (Linux, Solaris, HP-UX) directory. 
 
If you need any help to get your configuration up and running, send an email to 



support@isode.com.�

Things to check before you start (all) 

The purpose of the wizard is to create new Isode servers, listening on a number of TCP ports. 
It is important that no existing servers are using these ports, whether they be Isode or non-
Isode servers.  

The TCP ports that must be free for use by the Isode servers are:�

�
TCP Port Purpose  

25� � SMTP (M-Switch Internet)� �

102� � OSI (M-Switch X.400 and MIXER)� �

110� � POP3 (M-Box)� �

143� � IMAP (M-Box)� �

587� � SMTP Internal (M-Switch Internet)� �

2003� � LMTP (M-Switch Internet)� �

3001� � M-Store X.400� �

3002� � M-Store X.400 Management� �

18001� � Isode QMGR SOM (M-Switch)� �

18002  Isode QMGR (M-Switch)��

19389� � LDAP (M-Vault)� �

19999  DAP (M-Vault)� �

�
To identify and stop services that may be using these ports: 

·  On Windows, identify them and use the Windows service manager to stop them.� �

·  On Linux, identify them using netstat -np and stop them using their init scripts, e.g.  

/ et c/ r c. d/ i ni t . d/ ser v i ce st op 

·  On Solaris, identify them using lsof and stop them using their init scripts, e.g.� �

/ et c/ r c. d/ i ni t . d/ ser v i ce st op 

·  On HP-UX, identify them and stop them using their init scripts, e.g.� �

/  sbi n/ i ni t . d/ ser v i ce st op 

Any existing Isode MTA and client application configurations will need to be removed or 
overwritten. The client application files created are: 

�
File Application  

.emmarc� � EMMA��

.java/.userPresf/com/iso
de/mconsole� � Mconsole� �



.dmiHistory� � EDM��

.logview�� Event Viewer� �

~/.isode/sodium-
bindprofile.xml� � Sodium��

xuxaconfig.ini� � XUXA��

� �
The Isode services must only be installed on a machine with a static IP address, as changes to 
the IP address will make your messaging configuration unusable. 

Things to check before you start (UNIX only) 

You will need to create a new user “pp”, who is a member of the bin group. You may have a 
tool called “useradd”  that can be used to add users in the following way: 

# user add pp - g bi n 

 

 

�
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Using the Quick Configuration 
Wizard  

Windows 

Make sure you are logged in as an Administrator. 
 
From the Start menu, select Isode XX.X and then select Quick Configuration. 

Linux, Solaris and HP-UX 

Become root and execute the script: 

# / opt / i sode/ bi n/ qui ckconf i g 

Welcome Screen 

The screenshot below shows the initial welcome screen, with Next and Back and Quit 
buttons. 

 

You may quit at any time; however depending on the stage of your configuration, this may 
result in a misconfigured system. 
 
The introduction screen changes if an existing configuration is detected as shown below with 
a Remove existing configuration button. Clicking on this will stop Isode services and remove 
the existing configuration.  
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Click on Next to progress to the Configuration Screen. 

Selecting the Configuration Type 

As shown below you are now given a choice of configuration types to create. All 
configurations use the M-Vault X.500/LDAP directory. The current list includes: 

·  ISP (with anti spam): This configuration sets up M-Switch to be an Internet only 
MTA (SMTP/LMTP) with Anti Spam capabilities, which need to be configured 
beforehand. It also sets M-Box for IMAP/POP3 access. 

·  Aviation CAAS: This is a standard X.400 configuration, with the possibility of 
setting up an ATN Directory. The users are based on the CAAS Addressing Scheme��

·  Aviation MTCU: This is an X.400 configuration, specifically designed for a 
Gateway (MTCU) MTA. There are no local users.�  

·  Aviation XF: This is a standard X.400 configuration, with the possibility of setting 
up an ATN Directory. The users are based on the XF Addressing Scheme��

·  EDI: This is a standard X.400 configuration, with support for EDI content type� �
·  Military: A standard X.400 configuration, with support for military content types��
·  MIXER: This configuration demonstrates both X.400 and Internet capabilities in the 

servers, as it sets up M-Box (for IMAP/POP3 access)��
·  ISP (without anti spam): This configuration sets up M-Switch to be an Internet only 

MTA (SMTP/LMTP), without anti spam capabilities. It also sets M-Box for 
IMAP/POP3 access. 

·  Pure X.400: This "pure X.400" configuration doesn’ t have market specific settings.� �



 

Configuration type specific data 

Some configurations allow you to specify settings that are specific for the configuration type 
selected. For example, Aviation type configurations (CAAS or XF) allow you the choice of 
setting up an ATN Directory and load it up with Isode sample data. If your configuration type 
doesn’ t require configuration specific data, then this screen will not be shown. 

 

In the case of Aviation, you will also have the choice of entering the two letter code of your 
country (not the ICAO code, but the ISO code). Note that this is not XX, but the same two 
letter code that, for example, is used at the end of Internet addresses. 

Configuration data 



The image below shows the configuration screen. 

 

 
You will notice default values have been entered. You may alter any of these values as you 
wish, however the hostname must reflect the current machine (e.g. 
machinename.domain.com, or machinename). 

Note: If the MTA is to send and receive messages with other MTAs, then the 
fully qualified domain name should be used. 

The wizard will check the hostname being used, after the hostname has been updated and 
when a new box has been selected. 
 
Clicking on Single space ADMD will set the ADMD field to be “  ” . 
 
Click on the Next button to proceed. 

Port Scan 

The QuickConfig wizard will perform a port scan, making sure nothing is using the ports that 
M-Switch, M-Vault and M-Store X.400 (or M-Box) will use. 
 
This may take several seconds depending on your system. 



�

 
Currently QuickConfig can adapt if port 3001 is in use. The wizard will increment the port 
number until a free port is found and configure M-Store to use this port instead. Once finished 
the wizard will inform you of the ports it will use. 

Note: QuickConfig can only do this for port 3001. 

 

Configuration Creation 

The configuration will now be created using the values you have entered. The image below 
shows the creation of a new configuration. The configuration will be loaded into M-Vault 
(Isode©s directory server). When M-Switch is started, it will use the configuration in M-Vault. 

�



 

Default configuration files for Isode client applications are created automatically. 

Startup 

QuickConfig will now start the services. 

Note: The services required will look different on Windows and Unix. 

 

 

Sending an email: X.400 Mode 

You may select P7 or P3. As you select each option the default values at the top of the screen 
change to use correctly configured options. 

·  P7: This option causes the Send UA to bind to the P7 message store. The bind will 
use the username given in the From address, and the password given in Password. 
The P7 message store is listening on the presentation address given in Server. The To 
address will change to a user that has been configured to use the P7 Message store.� �

·  P3: This option will make the Send UA bind to the P3 server application entity, The 
bind will occur using the username in the From address and the password in the 
Password field. The P3 server application entity will be listening on the presentation 
address given in the Server field. The To address will automatically change to the 
user who is using the p3passive channel.� �

Select the type of connection you want. Then type in a test message. If you wish to blank the 
message area click on Clear, otherwise when you are ready click on Send. 
 
When sending/receiving an email for the first time you will have suitable default values. 
 
When using the send or receive user agents after that, an option will be displayed asking if 



you want to use Default or No Default values. The No Default option means the entry boxes 
(From, Password, To, Server) will contain nothing. 

You can also use Xuxa (the X.400 Demo User Agent) to send and receive X.400 messages. If 
you want to do that, click on the Launch Xuxa button.  

Sending an email: Internet Mode 

Sending is always done using SMTP. To receive a message, you may select IMAP or POP3. 
As you select each option the default values at the top of the screen change to use correctly 
configured options. 

·  IMAP: This option causes the Send UA to bind to M-Box, the IMAP and POP3 
Message Store. The bind will use the username given in the From address, and the 
password given in Password. The Message Store is listening on the host name and 
port shown in Server . The To address will change to a user that has been configured 
to use the IMAP Message store� �

·  POP3: This option will make the Receive UA connect to M-Box, using the username 
in the From address and the password in the Password field. The POP3 service will 
be listening on the host name and port shown in the Server  field. The To address will 
automatically change to the user who is was created as a POP3 user.� �

Select the type of connection you want. Then type in a test message. If you wish to blank the 
message area click on Clear , otherwise when you are ready click on Send. 
 
When sending/receiving an email for the first time you will have suitable default values. 
 
When using the send or receive user agents after that, an option will be displayed asking if 
you want to use Default or No Default values. The No Default option means the entry boxes 
(From, Password, To, Server) will contain nothing. 
 
This makes it easier for the person who is conducting tests to specify their own 
values. 

 



Receiving an email: X.400 Mode 

Select the protocol you wish to use, again choosing between P7, P3 . The User , Password 
and Server  fields will change to acceptable defaults. 

 

·  Show Body Only: The Show Body Only option will remove some header information 
so you just see the body of a message, and will attempt to make AMHS X.400 
messages look a little cleaner.�

Note: If the "Show Body Only"  option isn't selected you may receive warning 
messages when certain attributes are being read. These are due to missing 
optional attributes of the X.400 message, and can be ignored. 

 

·  Receive: When you are happy to receive a message, click on this button� �
·  Clear: Click on this button when you wish to remove all text from the messaging box� �
·  User : This is the user to bind as.� �
·  Password: This is the password of the user who is doing the bind.� �
·  Server: This is the presentation address the P7 message store or the P3 application 

entity will listen on.� �

Receiving an email: Internet Mode 

Select the protocol you wish to use, again choosing between IMAP and POP3 . The User , 
Password and Server  fields will change to acceptable defaults. 
 
When sending/receiving an email for the first time you will have suitable default values. 
 
When using the send or receive user agents after that, an option will be displayed asking if 
you want to use Default or No Default values. The No Default option means the entry boxes 
(From, Password, To, Server) will contain nothing. 
 



This makes it easier for the person who is conducting tests to specify their own 
values. 

Further Testing: X.400 configuration 

If you are testing an X.400 system, you can use XUXA, Isode’s X.400 Demo User Agent. 
You can launch the program from within QuickConfig by clicking on the Launch Xuxa 
button. As QuickConfig generates a configuration file to be used by Xuxa, you will be given 
the choice to import the text configuration file into the program, to proceed with the X.400 
testing. 
 
If you are testing a MIXER system (both Internet and X.400 protocols), you should do both of 
the steps above: configure Internet and X.400 email user agents. As X.400 networks are not 
usually publicly accessible, if you want to test interconnecting your system with another 
X.400 MTA, you can use the Isode Test X.400 MTA. 
 
Both sides of an X.400 connection need to be configured before messages can be exchanged. 
Your side of the configuration is performed automatically by QuickConfig, but the Isode 
MTA needs to know your details so we can configure our MTA to know about yours. 
 
If you want to connect to the Isode Test X.400 MTA, you should send an email to 
support@isode.com�will all the necessary information. The information we need is listed in a 
window that appears once you click on the Quit button. 
 
Please make sure your server is set up so that connections to port 102 are allowed from 
outside your network, as this is usually disabled by firewalls by default. 

Further Testing: Internet Configurations 

If you are testing an Internet system, you should configure your email client program, to send 
and receive messages using M-Switch. 
 
Any email client that supports SMTP, POP3 and/or IMAP (like Microsoft Outlook, Mozilla 
Thunderbird, Eudora, etc) will work with M-Switch. 
 
The way to configure these programs will vary, but the servers will always be the machine 
were you ran QuickConfig 
 
Port information 
SMTP Port: 25 for external access, 587 for internal access 
IMAP Port: 143 
POP3 Port: 110 
 
User  accounts: 
First test IMAP user name: imap.user1 
First test IMAP user password: imapsecret 
 
Second test IMAP User name: imap.user2 
Second test IMAP user password: imapsecret 
 
First test POP3 User name: pop.user 



First test POP3 user password: popsecret 
 
If your host in connected to the Internet, and has a correctly configured DNS entry and MX 
records, you will be able to send and receive Internet messages 

Summary 

You have now sent and received a test message. Click on Quit. Alternatively you can click on 
Back, and start using different connections. 
 
The QuickConfig wizard will notice there is an existing configuration and allow you to just 
send and receive messages the next time you run it.�

You have now: 

1: Created a basic configuration.  
2: Started the Isode services. 
3: Confirmed that the Installation, Configuration and Startup have been successful. 

�

�



Tools Overview 

This section covers the use of Isode management tools to examine the configuration as well 
as brief tutorials covering extending the evaluation configuration and removing an existing 
installation.�

At the end of this section you will have: 

1: Used MConsole to examine M-Switch X.400's queue and monitor operations.  
2: Used EMMA (Enterprise Messaging, Management and Administration), to view the 
directory based configuration of the messaging servers  
3: Used EDM (Enterprise Directory Management), to view directory server configuration  
4: Used Sodium (Secure Open Data, Identity and User Manager), to view data in the directory  
5: Used the standalone program Event Viewer or MConsole’s Event Viewer to monitor log 
files  
6: Used the Message Store Console to monitor connections 

MConsole�

Mconsole is an application designed to help monitor M-Switch, specifically the Queue 
manager.�To launch this tool:�
�
Windows�
�
Select the Start>Programs>Isode>Message Switch Console�menu item.�
�
Linux, Solaris and HP-UX�
 
Run: 

/ opt / i sode/ bi n/ mconsol e2 

 
Using MConsole�
 
In order to have full control over the message queue, you will need to bind to the queue 
manger with authorized access. This is already configured by Quick Config. So when you run 
the program: 

 

·  Show the MTAs by selecting View -> Switches� �
·  If it hasn©t connected, select your MTA, right click and select Connect 

More information about Mconsole is available in the M-Switch Administrators guide 
available from the Isode website at http://www.isode.com/support/docs.html.�

Enterprise Messaging Management Administrator 
(EMMA)�



EMMA is used to alter the configuration of M-Switch, and M-Store. To do this it binds to the 
Directory Server, and alters the configuration there. To launch this tool:�
�
Windows�
 
Select the Start>Programs>Isode>Enterpr ise Messaging Management and�
Administration menu item.�
 
Linux, Solaris and HP-UX�
 
Run: 

/ opt / i sode/ bi n/ emma 

�
Using EMMA�
 
Emma will have a configuration file created by the X.400 Quick Install wizard. Type� in the 
DSA password, which is “secret”  by default, and click on Connect.�
 
More information about EMMA is available in the M-Switch Administrators guide available 
from the Isode website at http://www.isode.com/support/docs.html. 

Enterprise Directory Management (EDM) 

EDM is used to configure directory servers. 

Note: This tool is not used to configure the contents of a directory server, but 
the configuration of the directory server itself. 

Windows 
 
Select Start>Programs>Isode>Enterpr ise Directory Management from the menu. 
 
Linux, Solaris and HP-UX 
 
Run: 

/ opt / i sode/ bi n/ edm 

Using EDM 
 
More information is available in the M-Vault Administrator guide available from the Isode 
website at http://www.isode.com/support/docs.html. Start EDM then: 

·  Click on File>Open  
·  Click on the pull down menu and select the existing value (it will look something like 

“cn=dsa, c=GB”)  
·  The username field will change to “cn=DSA Manager, cn=dsa, c=GB”, by default.  
·  Type in the password, this is the value of DSA Password shown in the configuration 

screen of the X.400 Quick Install wizard, which by default is “secret”   
·  Click on OK. 



Secure Open Data, Identity and User Manager 
(Sodium) 
 
Sodium is used to alter information within a directory. To launch this tool: 
 
Windows 
 
Select Start>Programs>Isode>Secure Open Data Identity and User  Manager  from the 
menu. 
 
Linux, Solaris and HP-UX 
 
Run: 

/ opt / i sode/ bi n/ sodi um 

 
You will need to bind to the directory server. The installation wizard will have created a bind 
profile for you to use. 
 
Click on the “Quick_install_config”  profile and click Connect. 
 
You will now be bound to the Directory Server. This shows a low-level view of your 
configuration. More information on Sodium is available in the M-Vault Administrators 
manual available from the Isode website at http://www.isode.com/support/docs.html. 

Event Viewer 

Isode release from R14.0 enable the viewing of logs from within MConsole. Just select the 
option View -> Event Viewer. 
 
M-Switch X.400 also contains the “Event Viewer” . This is a program that allows an 
administrator to monitor the logs of multiple machines remotely. The “Event Viewer”  
connects to isode.pp.somd running on the machine being monitored. 
 
Windows 
 
Select Star t>Programs>Isode>Isode Event Viewer. 
 
Linux, Solaris and HP-UX 
 
Run: 

/ opt / i sode/ bi n/ l ogvi ew 

 
Using Event Viewer 
 
Click on File>Open Connection>Quick_install_configuration. 
 
Select Monitor , and click on Select all. 



Message Store Console 

Isode’s Message Store Console allows you to monitor connections, see the number of unread 
messages per user, as well as other useful information. 
 
Windows 
 
Click on Star t>Programs>Isode>Message Store Console. 
 
Linux, Solaris and HP-UX 
 
Run: 

/ opt / i sode/ bi n/ xmsconsol e 

 
Using Message Store Console 
 
Using the X.400 quick test client send a message using the P7 option. 
 
Right click on the message store icon, and select Refresh. 
 
Expand the Mailboxes tree, to show all of the users. 
 
Select the user that you used as the recipient of the test messages, for example P7User1 . 
Then expand that user’s message tree. You should see the user’s unread mail below that 
user’s entry.�



� � � 	 
 � �
 
 � � � � � � � � 
 � �
 � � � � �� 
  
Please note: Further information on creating a configuration from scratch, and extending 
configurations is available in the M-Switch Administrator’s guide available from the Isode 
website at http://www.isode.com/support/docs.html.�

At the end of this section you will have: 

1: Learned how to extend your configuration by adding new users and testing that the new 
users have been setup correctly.  
2: Learned how to set up a connection to another X.400 MTA  
3: Learned how to remove an existing installation. 

Adding New users 

There are several different ways to add new users. This document covers the use of EMMA, 
which is the preferred mechanism. 

1. Open up EMMA and bind to the directory server. (To do so follow the instructions 
in the previous section).  

2. Click on Create, user .  
3. Now select the user template that matches the user you wish to create. In this 

example select CN User  (X.400 Message Store).  
4. A wizard will now pop up. Set the CN to “ testme” .  
5. Select the place under the OR tree you wish the user to appear. For example under 

OU=Sales should be ok, its under the machine name. Click on Next.  
6. Make sure the MTA associated with the user is correct. (It should be the hostname 

of your machine)  
7. You will need to associate a P7 Message Store with this user  
8. Click on the pull down menu, for the message store, and select the default message 

store  
9. Click on Next  
10. Type in a value for the users mailbox. This directory must exist, you should find that 

either C:\Isode\mailbox or /var/isode/mailbox has been created by the X.400 Quick 
Install wizard.  

11. Click on Next  
12. For both the passwords type in “secret”   
13. Click on Finish 

Checking User Addresses 

You can check user address within EMMA. 

1. Click on View, followed by User  Search� �
2. Click on the pull down menu Search for  a.., select the user template which 

corresponds to the type of user you are searching for, in this case select CN (X.400 
Message Store User)� �

3. Click on Search� �
4. A list of users will be displayed.� �
5. Click on the new test user .� �
6. Click on Check Address.� �



Sending and Receiving Messages: Xuxa 

There are several ways to send and receive X.400 messages. You can use Xuxa (the X.400 
Demo User Agent), use the Quick Config send UA, or use any of our Tcl, Java or C sample 
programs. This evaluation guide concentrates on the easier to use programs: Xuxa and the 
Quick Config send UA. 

Launching Xuxa: Windows 
 
Run Start>Programs>Isode>X.400 Demo User  Agent 
 
Luanching Xuxa: Linux, Solaris and HP-UX 
 
Run:�

/ opt / i sode/ bi n/ xuxa 

Using Xuxa 

The first time you run Xuxa after creating a configuration with Quick Config, the program 
will inform you that the user configuration has been imported. Then it will connect to the 
X.400 P7 Message Store, and list the user mailbox. 
 
You cannot manually enter addresses in Xuxa (this is a design choice), you need to select 
them from the Address Book. Quick Config creates a number of users and adds them to the 
public Address Book. In order to send a message to yourself, first click on the Write icon, 
then click on the small orange address book icon. This will call the Address Book. Navigate 
and expand the Address Book until you find your own entry (your O/R address is in the title 
of Xuxa©s main window). Either double click on the address or select it and click on the "To: -
>" button. Then click on OK. Finally write something in the Subject and body part of the 
message and click on Send. 
 
You should immediately receive a copy of the message, and since by default Delivery Reports 
(DRs) and Inter Personal Notifications (IPNs) are requested, you should receive a DR straight 
away, and an IPN seconds later. Click on the Get Mail icon to refresh the contents of your 
inbox. 
 
You can configure other accounts using Xuxa (File -> Preferences). For more information, 
refer to the Xuxa Manual (http://www.isode.com/Documentation/XUXAADM.pdf) 

Sending and Receiving Messages: Quick Config 
UA 

If you haven©t quit the program, you can still use it to send messages from one user to another, 
for example, the one that Xuxa is using. If you have quit the program, it is still possible to 
send and receive X.400 messages using Quick Config UA. 

Launching Quick Config UA : Windows 
 
Run Start>Programs>Isode>Quick Configuration 
 
Luanching Xuxa: Linux, Solaris and HP-UX 



 
Run:�

/ opt / i sode/ bi n/ qui ckconf i g send 

 
 
Using the X.400 Send UA 
 
You will be given the option of selecting Default and No Default values. Make sure Default 
is selected. 
 
You need to enter in the new “ testme”  user as the From address. Because you created the 
"“CN=testme”  user under “OU=lppt” , you should be able to just remove the default 
“ /CN=lppt1” , and replace just that section with “ /CN=testme” . 
 
Next change the Password to “secret” . 
 
Type in a message and click on Send. 
 
You will bind as the new “ testme”  user, and submit a message. Click on Receive UA. You 
will now receive the message you have just sent. 

Using the X.400 Recieve UA 

You should send a message to the “ testme”  user. Click on Send UA so you are at the send 
UA. 
 
Change the To address to be: 

/ CN=t est me/ OU=l ppt / O=<your _or g_name>/ PRMD=Test PRMD/ ADMD=Test ADM
D/ C=GB/  

 
Note: This is assuming you©ve kept the default values 
 
Click on Send to send the message. 
 
Click on Receive UA. 
 
The User value is the person you are connecting to the P7 Message Store as. It will 
automatically change to match the To address on the Send UA, so by default you will bind to 
the message store and read the message you’ve just sent. Make sure the password is correct 
for the “ testme”  user. 
 
Click on Receive. 

Setting up a connection to another X.400 MTA 

The configuration wizard has an entry box External MTA. You must enter the correct 
domain name for the machine you are testing against. 
 
In this example the two machines are “host.example.com” and “remote.example.com”. The 
example will describe how to quickly create two totally separate configurations. In a 



production system you would really only have one directory server, and keep all of the MTA 
configuration information in it. 

� �  Run the Quick Config install wizard on host.example.com.� �

� �  Make sure the hostname is the fully qualified domain name of the host machine� �

� �  Make sure the external MTA is set to “external.example.com” � �

Now repeat steps 1-3, but using the Quick Config install wizard on the “ remote.example.com” 
machine, swapping “host.example.com” for “ remote.example.com”. 
 
The installation wizard will setup all of the authentication information for both machines. 
 
Open the send and receive clients on both machines. 
 
Send a message to 
“ /CN=lppt2/OU=lppt/O=remote/PRMD=TestPRMD/ADMD=TestADMD/C=GB/”  from the 
host.example.com machine, the receive client on the remote.example.com machine should 
receive the message. 

Removing an Existing Installation 

The Quick Config install wizard can remove most of the configuration for you. 
 
Open the Quick Config install wizard. Click on the button marked Remove Existing 
configuration. 
 
You should then remove the Isode packages in the appropriate way for the platform. 
 

Congratulations! You have just set up a working X.400 Quick evaluation 
system. During this evaluation you have: 

1: Created a basic X.400 configuration 
2: Started the Isode services 
3: Confirmed the installation, configuration and startup have been successful by Sending a 
test X.400 message through the system, and retrieving it using the X.400 quick test client  
4: Used EDM to check the M-Vault DSA was created successfully 
5.: Used Sodium  to check the M-Switch X.400 configuration was successfully loaded into the 
M-Vault DSA   
6: Used EMMA to browse the M-Switch X.400 configuration  
7: Used Mconsole to monitor the MTA and the Event Viewer to monitor the MTAs logs  
9: Used the Message Store Console to check users unread mail  
10: Extended your configuration to include an additional user using EMMA  
11: Optionally added an additional X.400 MTA to communicate with. 



What next/other resources? 
This guide has taken you through the process of setting up a X.400 Evaluation System. For 
those interested in a deeper understanding of the tools used during this evaluation, 
Administration Guides for M-Switch, M-Vault and M-Store can be downloaded from the 
Isode website at at http://www.isode.com/support/docs.html. 

Product Information 

Product information on the various servers and management tools used and referenced during 
this evaluation can be found at the following locations: 

·  M-Switch X.400:  http://www.isode.com/products/x400.html  
·  M-Store X.400: http://www.isode.com/products/x400-store.html  
·  M-Switch MIXER: http://www.isode.com/products/m-switch-mixer.html  
·  M-Vault: http://www.isode.com/products/m-vault.html  

 

·  MConsole: http://www.isode.com/products/m-switch-management.html#monitor�  
·  EMMA: http://www.isode.com/products/messaging-configuration.html  
·  EDM: http://www.isode.com/products/edm.html  
·  Sodium: http://www.isode.com/products/sodium.html  
·  Event Viewer: http://www.isode.com/products/messaging-operation.html#event  
·  XUXA: http://www.isode.com/products/xuxa.html  

�  

Whitepapers 
 
Free Isode whitepapers are available from the website which cover all Isode products and 
solution areas. All Isode whitepapers can be found from  
http://www.isode.com/whitepapers/index.php, with X.400-specific papers located at 
http://www.isode.com/whitepapers/white-x400.html�and Internet Messaging specific papers 
found at http://www.isode.com/whitepapers/white-int.html.  
 
If you want to be informed about new whitepapers, you can sign up for the Isode News email 
list at http://www.isode.com/company/news-request.php.  


