
M-Link Instant Messaging & 
Presence Server Evaluation 
Guide
Setting up and using Isode's M-Link XMPP Server.



Objectives

This document is intended for those evaluating Isode's M-Link XMPP Server. M-Link uses directory 
(LDAP) based configuration and as such will require an existing Isode M-Vault server or the 
installation of a new Isode M-Vault server.

For the purposes of this evaluation guide we have assumed that this is a 'clean' installation. The guide 
will therefore take you through the process of installing M-Vault as well as M-Link.

Please do not 'Mix and Match' M-Vault and M-Link Versions. If you're installing R14.4 M-Link, make 
sure that M-Vault is also R14.4 and  not an earlier version.

By the end of this guide you will have:

1. Installed and activated Isode's M-Link XMPP Server and M-Vault LDAP Directory.
2. Exchanged XMPP messages between 'users' (set up during the Internet Messaging 

Evaluation Guide) using the freely available 'Psi' XMPP Client.
3. Explored M-Link's 'roster pre-population' and 'peering controls' functions.
4. Set up M-Link's multi-user chat (MUC) room capability allowing for the  creation of 

temporary and permanent MUC rooms.
5. Installed and used Isode web-applications for M-Link.

Isode packages filenames always contain references to the version number of the package, as do some 
of the third-party packages required in the later stages of this guide (like Apache Tomcat). For the 
purposes of this guide version number have been replaced with a generic ‘X’. For example: M-Link-
14.6v0-0.i386.exe becomes M-Link-XX.XvX-X.i386.exe. 

You should substitute the relevant version numbers when running commands or executing menu items 
that include package names.

Installation

Before installing any Isode applications on your machine, you should check which operating systems 
are supported by visiting www.isode.com/products/supported-systems.html.

Evaluation downloads (excluding documentation) are held in a password-protected section of the Isode 
website. If you have not already done so you should apply for password access by filling in the form 
located at www.isode.com/evaluate/evalrequest.php.

In addition to installing M-Vault and M-Link, you will need to download and install the Java 
Development Kit (JDK) Version 5.0 or above (http://java.sun.com/javase/downloads/index.jsp). You 
should install this before installing any Isode packages.
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Installing M-Vault & M-Link

After obtaining password access to the Isode binary files you should download and install the 'Tcl, Tk 
and Tix' package as well as M-Vault and  M-Link. Installation instructions relevant to your platform 
are available on the product download pages.

Note: On Linux platforms you should create an M-Link runtime user account “mbox”. After 
installation you should change the ownership of the /etc/isode directory to this user.

The 'ms.conf' File

The download page for your platform will also instruct you to download an 'ms.conf' file for 
configuration purposes.

 Windows: Save this file into \Isode\etc\ 
 Linux: Save this file into /etc/isode 

The LDIF file

The download page for your platform will also instruct you to download an LDIF file. You'll need this 
file later on in the evaluation, so save it to a safe place.

The Isode License File

Isode products require a valid license from Isode before they will run correctly. Licenses are issued by 
Isode Customer Service. If you haven't already been sent a licence when requesting access to the 
evaluation files, please send a message to request a license to sales@isode.com  remembering to 
specify which Isode server products you need a licence file for (in this case M-Vault and M-Link). By 
default the license file you receive needs to be installed in \Isode\etc\ as 'license.dat'. You may have 
chosen an alternative installation directory when installing the software, in which case you will have to 
place the license file there.

HTML & Video Version

A HTML version of this evaluation guide, accompanied by video clips, is available on the Isode 
website. The start of the HTML guide can be found here.

Wherever you see the 'Play' symbol (above), you can click on that symbol to go directly to the HTML 
page that contains the video illustrating that section of the evaluation guide.
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Creating and Populating a new Directory

M-Link uses a LDAP directory to hold configuration information. In this next section you are going to 
use 2 Isode GUI tools to create and populate a directory:

 EDM is used to configure and manage the Directory Service. It is used for initially setting up 
the Directory Service. It can be used to operate Directory Servers and to maintain operational 
information for the modification and extension of the Directory Service (as opposed to user in-
formation, which is maintained by a Directory User Agent (DUA) such as Isode’s Sodium).

 Sodium (Secure Open Data, Identity and User Manager) is used to manage user information in 
the Directory (such as entries for people or organizational units). It allows you to manage user 
information on multiple Directory Servers across the network, bulk load & dump data, browse 
through the Directory & add, delete and modify entries.

Starting EDM

In Windows click Start, and from the Programs menu, select Isode RXX.X>Enterprise Directory 
Manager (EDM).

In Linux login as the user of the DSA account. You need to do this because the DSA configuration 
directory is created when you add a new Directory Server in EDM, and the DSA account must be the 
owner of the DSA configuration directory. Then type the following command:

% /opt/isode/sbin/edm

This command uses the X11 windowing system; it will attempt to display either on the current display, 
or on the display that has been specified using the standard X11 DISPLAY variable.

Creating a New Directory Server with EDM

We're going to create a standalone Directory Server which will represent the organization 'MyISP'. To 
create a new Directory Server:

 From the File menu, select New>Directory Server. The initial Directory Server Creation 
Wizard screen is displayed.

 As this is a standalone Directory Server, leave Be used to master information selected and 
click Next.

 From the It will master a: drop down list, select International Organization.
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 In the o= text box, type ‘MyISP’ - the name of our example company. Click Next.

 This screen allows you to enter the Distinguished Name of the Directory Server’s entry in the 
DIT. In this instance, leave the cn=dsa as the default dsa, and click Next.
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Unless a Directory Server has been previously created on this system, the default will work. Otherwise, 
the last part of the directory path will need to be changed from dsa-db to something like dsa-db2 as no 
two Directory Servers can have the same configuration path. The wizard will display an error if you 
specify a directory location that already exists.

 Edit the Configuration path, if necessary.
 Click Next.

The DSA Manager’s password screen is displayed. Type in the password for the DSA Manager 
(“secret”), and then re-enter it in the Confirm Password text box.

Note: You'll need this password later on to connect to the Directory Server. If you do not 
use the suggested password of “secret” you'll need to edit the ms.conf file you saved on 
Page 3 so that the <ldap_bind_pwd> variable is set to your password.

Click Next to proceed to the final summary screen:

Check the 'Start the new directory server once it has been created' radio button and then click 
Finish. EDM will now create and start your new Directory Server, a confirmation message will pop-up 
after this has been done. You now need to set up SASL for your domain. From the File Menu select 
'Open', choose the MyISP Directory server from the dropdown list, enter the password 'secret' and 
click on OK.
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Click on the 'cn=DSA' entry and select 'directory Server Properties' from the drop-down list.

Navigate to the SASL tab and in the 'Defaults section set the default SASL domain to be 'myisp.net' 
and the SASL username for the DSA Manager to be 'Manager@myisp.net'.

Next in the 'Generic Mappings' section, click on the 'Active Directory Compatible' radio button and set 
the following properties:

 AD DN Suffix:cn=Users,cn=Messaging Configuration,o=MyISP 
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 Username Attribute: cn 

Click on 'OK' to commit these changes.
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Populating & Browsing the Directory using 
Sodium

Isode provides a Directory User Agent (DUA) called Sodium as part of the M-Vault installation. 
Sodium can be used, amongst other things, to manage user information in a Directory.

In this section we’re going to use Sodium to populate the Directory we've just created with the user 
details that M-Link will use.

Starting Sodium

In Windows, click Start and from the Programs menu, select Isode RXX.X> Secure Open Data, 
Identity and User Manager (Sodium). On Solaris/Linux, type in the following command:

% /opt/isode/bin/sodium

Binding to the Directory Server

Select Bind > Connect from Sodium’s Session menu. As you have no currently configured binds, the 
Bind Profile Management screen will be displayed.

Click on New and in the Bind Profiles Details screen select LDAP and define the hostname as 
'localhost'.
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Click on Next, select the Simple authentication radio button and fill in the Bind DN field with the 
following: 

cn=DSA Manager, cn=dsa, o=MyISP

You should type into the Password field, the password you set and noted down earlier. Click on 
Finish.

You are now connected to the Directory Server and the initial World view is displayed.

On the download page for your platform, you’ll find a link to a sample ‘MyISP’ LDIF (LDAP Data 
Interchange Format) file. You should save this file to a convenient location. Data cannot be loaded 
directly under ‘World’ so firstly expand the tree by clicking on the ‘+’ to reveal the current entries in 
the DIT as above.

Make sure that you have the ‘MyISP’ Entry selected, right-click and select ‘Bulk Tools >LDIF 
Load..’ from the pop-up menu and you’ll be presented with the LDIF Bulk Load Settings screen.

Browse to where you saved the sample LDIF file and click OK to load, accepting the default settings 
that the load screen presents you with. Sodium will load the entries into the directory.
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Install M-Link Services (Windows Only)

From the Start menu select Isode XX.X and then select Services and then select Install M-Link 
Services.

Create Default Isode Services (Windows Only)

Click Start and from the Programs menu select Isode RXX.X>Services>Isode Service Manager. 
From the Service menu select Create default Isode Services.
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Start M-Link

Now that you have created your directory, started it and populated it with some data you can now start 
M-Link.

 Windows: In the Service Manager (previous screenshot) highlight M-Link and click on the 
Start button.

 Linux: From the command line:

# /etc/init.d/mlink start

Congratulations

You have now installed M-Vault and M-Link, started both servers and populated M-Vault 
with user identities.

In the next section we're going to test the M-Link installation using the popular 'Psi' XMPP 
client.  You may also wish to try adding additional users to your trial  installation using 
Sodium. Instructions on how to do this can be found in the main M-Vault evaluation guide 
(www.isode.com/evaluate/m-vault.html)  in  the section 'Adding  an entry/entries  using 
Sodium'.
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Installing the Psi Client & Testing one-to-
one chat.

A number of freely available XMPP clients are available but for the purposes of this evaluation we're 
going to use the cross-platform Psi client, available for free from http://psi-im.org/.

Installing and Using Psi

Download, install and run Psi. When starting Psi for the first time, select the 'Use existing Account' 
option. In the setup screen you're presented with, use the ID and password details from one of the users 
you've already imported into the directory.

You can browse the available users in this setup (which is a 2 domain system 'myisp.net and 
'acme.com') by using Sodium to examine entries under 'cn=Users'.  In the case below we've used:

 ID: emily.fox@acme.com

 Password: password

ID and password information for all of your entries can be found in Sodium by highlighting any of the 
user entries and checking the contents of the Contact and Security tabs.

You'll also need to give the account a name, we've used 'Emily Fox'.

On the 'Connection' tab, tick the 'Manually Specify Server Host/Port' option and enter 'localhost' as the 
server name.
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Set the Encrypt Connection option to 'When available' and the Allow plaintext authentication option 
to 'Always'. Click on Save and the Close  the setup box. The main Psi roster screen will be displayed, 
you can go online by selecting the Online setting from the status dropdown:

In Psi under the General/Account Setup menu option, set up a new account this time using the 
password and login details for the 'George Robson' user.

 ID: george.robson@acme.com

 Password: password

As we're using 'roster pre-population' (see the next section), once you log in as both users you'll notice 
that each user is listed as online in the roster of the other. The two screenshots that follow show each 
user logged in with the other appearing in their roster under the 'finance' roster group.
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Roster Pre-Population

The supplied LDIF file, loaded into the Directory earlier, includes a number of pre-populated roster 
groups. 

These groups will pre-populate the rosters of the users with the details of other users in the same 
group.

In the example above we've shown how roster pre-population works from the client perspective by 
setting up accounts for George Robson and Emily Fox, who are both members of the 'finance' group. 
The screenshot below shows the finance group in the directory, via Sodium.

As you can see, the finance roster group consists of Emily Fox, Vaughn Whiting, George Robson and 
Sally Brown.

Pre-populated groups are an excellent way of ensuring that users (new and existing) have immediate 
access to those contacts within your organization that they ought to be talking to and avoids the 
occasional problem of users 'missing' requests from other users requesting access to their presence 
status.
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M-Link and Multi-User Chat (MUC)

M-Link allows for both ad-hoc and permanent (or persistent) MUC rooms.

Enabling MUC

MUC services have already been enabled in the settings of the LDIF and ms.conf files that you used 
earlier with the chat domain 'talk.acme.com'. A number of permanent chat rooms have been set up, 
with membership of those chat rooms restricted to the same groups as are being used for roster pre-
population. In the screenshot below we can see that George Robson is the owner of the chatroom and 
that it's membership consists of the members of the finance group.

To demonstrate how these restrictions work, attempt to join the Finance or Sales chatrooms as the user 
George Robson by right-click and selecting 'Service Discovery' from the menu.
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You'll see in the resulting window that all of the multi-user chatrooms set up in the directory are listed. 
However, attempting to join a chatroom that George Robson is not a member of (such as the Sales 
room) will result in an error message.

Ad-hoc Chat Rooms

You can create an join an ad-hoc chat room from the Psi client. Select 'Join Groupchat'

  

If you've been following this guide, and are using the same instance of Psi to run both of the identities 
you're using with M-Link, you need to select one identity to join the room as. You'll need to name the 
room  and give yourself a nickname used within the room. Click on 'Join' to create and join the room as 
a Moderator. Only the Moderator will have access to the Psi client's room configuration options.

Permanent Chat Rooms

The Moderator of an ad-hoc chat room can turn it into a Persistent or Permanent Chat room by ticking 
the Persistent Room option on the General tab of the Configure Room options menu. Permanent 
chat rooms created in this way will be written back to the directory and can be managed via Sodium in 
the same way as the existing permanent chat rooms we've already seen.
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Using Isode Web Applications with M-Link

In this final section we're going to install and examine Isode's web applications for M-Link and use 
them to add an M-Link user. Isode's web applications for M-Link consist of:

 IMAdmin-Personal: Management pages for individual system users including a Directory 
Browser, personal information and password management. After installation.

 IMAdmin-Delegated: Delegated administrator's page which allow administrators to perform 
administration tasks appropriate to a specific realm.

 IMAdmin-System: Functionality which allows system administrators to create and manage 
system-wide settings.

Isode's web applications for M-Link are part of a larger suite of web based management tools which 
includes functionality for M-Link, M-Box (POP/IMAP Message Store) and M-Switch (SMTP 
Message Switch). The ms.conf file controls which product-specific functions are activated. In this 
example we're looking only at the M-Link related functions. For  information on other web 
applications, please consult the Web Applications Administration Guide available from the Isode 
website at: www.isode.com/support/docs.html 

By the end of this section you will have:

1. Installed and activated Isode's web applications for M-Link.
2. Taking  the  role  of  an  administrator,  added  a  new  M-Link  user  to  your  instant 

messaging configuration.

Installing and Activating the Web Applications (Windows)

Click Start and from the Programs menu select Isode RXX.X>Web Applications Setup Utility and 
follow the instructions in the setup wizard, answering 'yes' when asked if you wish to install the *war 
files.

You can now start Tomcat via the Isode Service Manager (Isode RXX.X>Services>Isode Service 
Manager).

Installing and Activating the Web Applications (Linux)

On Linux, type in the following command to set up the Isode web applications:

# /opt/isode/sbin/isode-tomcat-setup

Follow the instructions in the setup wizard, answering 'yes' when asked if you wish to install the *war 
files. You should now start Tomcat:

# /init.d/isode-tomcat-start
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Using the Web Applications

In the following section we're going to log on to IMAdmin-System as an Administrator and add a user 
to our M-Link instant messaging system. Isode web applications are available at the following 
addresses:

 IMAdmin-System: http://localhost:8080/imadmin-system/ 
 IMAdmin-Delegated: http://localhost:8080/imadmin-delegated/ 
 IMAdmin-Personal: http://localhost:8080/imadmin-personal/ 

Launch your browser and navigate to http://localhost:8080/imadmin-system/. The default administrator 
login for this system is:

 User Name: Administrator
 Password: secret

System Administrators have access rights to all administration tasks including creating administration 
realms  (a collection of one or more domains), assigning users to administration realms and giving 
them administration roles (such as giving them delegated admin rights over a realm). You can find out 
more about Roles, Realms and Groups from the Web Applications Administration guide. In this guide 
we're simply going to add another user to our existing M-Link setup, so click on Users from the main 
menu and then on the 'Add new user' link.

M-Link Instant Messaging and Presence server Evaluation Guide: Page 19



The minimum amount of information you'll need to fill in on the new user form is Account Name, 
Password and Surname.  You can enter any information in these fields, in this guide we're creating a 
new user called 'mike.smith@acme.com'.

Click on Save to commit your changes and you'll be returned to the user list screen. You'll now be able 
to log on to your M-Link instance as 'Mike Smith' using your instant messaging client. Additional 
users will also show up in Sodium, although you may need to refresh the directory tree (right-click on 
cn=Users and select 'refresh').
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A note on DNS

This guide runs through the process of setting up M-Link for instant messaging and presence 
evaluation on a single, local machine.

XMPP client and other XMPP servers use DNS (Domain Name Service) records to locate the machine 
on which M-Link is running. If you run the server for the domain "example.com" on a machine that 
has DNS A records for either "example.com" for "xmpp.example.com", no special DNS configuration 
changes are required.

If the machine has a different name or if you run with non-standard ports, you will have to set up DNS 
SRV records (Service records) so that clients and other XMPP servers can correctly locate your M-
Link server. We recommend always setting up these records for a production server. DNS can also be 
used to configure a server for access from inside and outside a company LAN. For example, the 
external DNS configuration for the isode.com XMPP server has two SRV records. The first record is 
used by XMPP clients, and tells them to connect to TCP port 5222 at firewall.isode.com:

_xmpp-client._tcp    IN    SRV 5 0 5222 firewall.isode.com

The second is used by other XMPP servers, and tells them to connect to TCP port 5269 at 
firewall.isode.com:

_xmpp-server._tcp    IN    SRV 5 0 5269 firewall.isode.com

The internal DNS again has two SRV records but these point to the internal machine instead of the 
firewall.

_xmpp-client._tcp    IN    SRV 5 0 5222 internal.isode.com
_xmpp-server._tcp    IN    SRV 5 0 5269 internal.isode.com

M-Link Instant Messaging and Presence server Evaluation Guide: Page 21



What next/other resources

Product Information

While following this guide you have installed M-Link (XMPP Server) and M-Vault (LDAP/X.500 Dir-
ectory Server). For more information on these server products, follow the links below:

 M-Link: www.isode.com/products/m-link.html  
 M-Vault: www.isode.com/products/m-vault-directory.html 

You have also used Sodium (directory data management) as well as the web-based IMA (Internet Mes-
saging Administrator). For more information:

 Sodium: www.isode.com/products/sodium.html
 IMA: http://www.isode.com/products/ima.html 

Exploring Product Capabilities

This guide has covered only the basic functionality of Isode's M-Link server. To extend your system 
and explore the capabilities of M-Link further you should read the Administration Guide available 
from the Isode website in PDF format. The M-Link Administration Guide, together with all other Isode 
documentation is available from: www.isode.com/support/docs.html 

Whitepapers

Isode regularly publishes whitepapers relevant to XMPP. All whitepapers can be searched from the 
whitepaper index page on the Isode website at:

www.isode.com/whitepapers/index.php 

M-Link and Security Labels

M-Link provides control of messages based on security labels associated with those  messages. Isode 
supports security labels according to XEP-0258 (Security Labels in XMPP) with support for S/MIME 
ESS Labels (RFC 2634 "Enhanced Security Services for S/MIME") and for Isode XML Labels. 
Controls are based on Security Clearance of Sender, Recipient, and peer XMPP server. Security Label 
based controls are also provided for MUC.If you would like to try M-Link with Security Labels, 
instructions for implementing a 'uk-demo' security policy can be found in the readme.txt file located at:

C:/Program Files/Isode/share/security-labels/example-data/uk-demo/ (Windows)

/opt/isode/share/security-labels/example-data/uk-demo/ (Linux)
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The Isode Logo and Isode are trade and service marks of Isode Limited.

All products and services mentioned in this document are identified by the trademarks or service 

marks of their respective companies or organizations, and Isode Limited disclaims any 

responsibility for specifying which marks are owned by which companies or organizations.

Isode software is © copyright Isode Limited 2002-2006, All rights reserved.

Isode software is a compilation of software of which Isode Limited is either the copyright holder or 

licensee. Acquisition and use of this software and related materials for any purpose requires a 

written licence agreement from Isode Limited, or a written licence from an organization licensed 

by Isode Limited to grant such a licence.

This manual is © copyright Isode Limited 2010.
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