This document briefly describes how to configure and extend HP OpenView 6.31 to monitor M-Switch and M-Vault via osiappd.

Configure OIDs

Create a new file in in OpenView's conf\oid_to_sym_reg\001_HP directory called 002_HP_Isodefile and add a line to map a symbol to osiappd:

1.3.6.1.4.1.453.9.1.1:Application:Mail # Isode osiappd

Edit the conf\oid_to_type file, though this doesn't seem to be useful:

1.3.6.1.4.1.453.9.1.1:Isode:Isode osiappd # Isode osiappd

Edit the fields\C\ovw_fields file in OpenView to add Isode as a vendor name:

Field "vendor" {
Type Enumeration;
Flags capability, general, locate;
Enumeration "Unset",
...
"Isode",
...
"Xyplex"
;
}

Similarly edit fields\C\snmp_fields to add Isode osiappd as an SNMP agent:

Field "SNMPAgent" {
Type Enumeration;
Flags capability, general, locate;
Enumeration
"Unset",
...
"Isode osiappd",
...
"4BSD ISODE";
}

Import MIBs

The next stage is to restart OpenView and import the MIBs we support.

Start by downloading RFC 1566 and RFC 1567. Edit the files so that they just contain the MIB definitions without all the RFC header/footer text.

In OpenView go to "Options>Load/Unload MIBs: SNMP", click the "Load..." button and locate the MIB you want to load in.

Build Applications

You need to build an "application" for each window that you want to put SNMP information into.

In OpenView go to "Options>MIB Application Builder: SNMP". In the window that appears, go to "Edit>New..."

In the dialog that appears enter some unique short string for the application ID (eg MTA). Choose the Application Type - either a Form (values displayed in vertically arranged fields), a Table (values are columns in a table) or Graph. Enter the Application Title: this is used as the window title. Hit "Next..."

Hit "Add..." to select the particular fields of the MIB that you want to display. For example, ".iso.org.dod.internet.mgmt.mib-2.mta.mtaTable.mtaEntry.mtaReceivedMessages". Hit "Add" for each one you're intersted in, and then hit "Close".

In the "Display Fields" window you can tweak the labels of these fields. Hit "Next..." when done.

In the "Menu path" you can basically construct the main window's Configuration menu. Something like "Configuration->MTA" will add an "MTA" item to the Configuration menu. You don't need to change the Selection rule at all. Hit "Finish" and then choose "File>Close".

Build Maps

The main OpenView window basically shows a hierarchical view of your network. Double-clicking a symbol in each view (called a map) displays a more detailed view of that symbol (called a submap.)

To monitor an MTA you therefore need to construct the hierarchy down to the computer the MTA (well, osiappd) is running on. Double-click the Internet map, choose "Edit>Add Object...", click on Network in the top pane and drag "IP Network" from the bottom pane into the submap. An Inspector window appears.

In the Inspector, click "IP Map" and "Set Object Attributes...". Click on Network Address and enter the IP address of the entire network (eg 192.168.1.0), hit "OK". Check the Network Subnet mask is OK. If everything's consistent, the "OK" button will be enabled - hit it. In the "Selection Name" enter some descriptive name for the icon. Hit "OK". Double-click the icon you just created.

Duoble-click the Segment icon that appears.

Choose "Edit>Add Object...", click on Application in the top pane and drag "Mail" from the bottom pane into the submap. An Inspector window appears.

Click on "IP Map" and "Set Object Attributes...". Set the IP Address, and then hit "OK". Hit "General Attributes" and "Set Object Attributes...". Click "isSNMPSupported" to turn it to "true". Click "SNMPAgent" and choose "Isode osiappd" from the list. Click "Preferred SNMP Address" to the hostname running osiappd. Click "vendor" and choose "Isode" from the list. (They're both probably at the end of the list.) Hit "OK" and "OK" again to close the Inspector.

Monitor the Application

Click on the Mail application icon, and choose "Configuration>MTA" (or whatever menu name you configured in the MIB application builder. A window will appear according to your configuration.

I found that I had to stop and restart OpenView several times in order for some configuration changes to take effect, in particular before opening my first monitor window.

Multiple Agents

OpenView will only manage one SNMP agent per hostname. If you need to manage more than one, create extra hostnames with the same IP address (eg in the DNS), and use the xnmsnmpconf program to set up the remote port on each specific node to whatever port each agent is listening to.