Oracle Java and Isode Products

Some components of release R17.0 are written in Java. You should install any Java dependencies before installing the following components of the Isode packages:

  • Sodium
  • M-Vault Console
  • Log Configuration
  • Isode Service Configuration
  • MConsole
  • M-Link Console
  • Web applications

If you do not require these components then you do not need to install Java.

Oracle has announced that Java updates for commercial customers ends after January 2019. See(https://www.oracle.com/technetwork/java/java-se-support-roadmap.html ).

For R17.0v7 and later, Isode recommend commercial users of Java who do not wish to purchase support from Oracle, to use Isode’s “OpenJDK for Isode” package instead. This is available from www.isode.com This contains a copy of the OpenJDK (see http://jdk.java.net) which has been tested for compatibility with R17.0, and is fully supported for use by Isode applications.

Isode will not be updating versions prior to R17.0 to work with Java 11. Commercial users using these releases will have the following options:

  • Upgrade to R17.0
  • Run with a version of Oracle Java 8 which will, after January 2019, no longer receive updates from Oracle
  • Obtain a suitable commercial license from Oracle for a supported version of Oracle Java 8 (which will receive updates after January 2019)

Isode R17.0 is supported with Oracle Java 8 and Oracle Java 11. A future version of Isode will remove support for Java 8.

After Java 8, the next LTS (Long-Term-Support) version of Oracle Java is Oracle Java 11. Commercial users of Oracle Java 11 are required to purchase a license from Oracle.

Commercial users may purchase extended support for Oracle Java 8 if they wish to deploy it after January 2019.

One Reply to “Oracle Java and Isode Products”

Comments are closed.